Northland DHB eReferrals submission failures

Incident Report for HealthLink Service Status

Resolved

This incident has been resolved.
Posted May 19, 2026 - 14:32 NZST

Investigating

Customers will have issues submitting Northland DHB eReferrals form
Posted May 19, 2026 - 14:30 NZST